You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/gkwebmon/gkwebmon-0.2.1.ebuild

36 lines
713 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A web monitor plugin for GKrellM2"
HOMEPAGE="http://gkwebmon.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc x86"
# The Makefile links with -lssl.
RDEPEND="
app-admin/gkrellm:2[X]
dev-libs/glib:2
dev-libs/openssl:=
x11-libs/gtk+:2
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-0.2-cc-cflags-ldflags.patch
"${FILESDIR}"/${PN}-0.2-fno-common.patch
)
src_compile() {
tc-export PKG_CONFIG
emake CC="$(tc-getCC)"
}