You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/pidgin-musictracker/pidgin-musictracker-0.4.22....

42 lines
823 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="A Pidgin now playing plugin to publicise the songs you are listening"
HOMEPAGE="https://code.google.com/p/pidgin-musictracker/"
SRC_URI="https://pidgin-musictracker.googlecode.com/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~riscv x86"
IUSE="debug"
DEPEND="
dev-libs/dbus-glib
dev-libs/libpcre
net-im/pidgin[gtk]"
RDEPEND="${DEPEND}"
BDEPEND="sys-devel/gettext"
PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
src_prepare() {
default
sed -i -e "s/DOMAIN/PACKAGE/g" po/Makefile.in.in || die
eautoreconf
}
src_configure() {
econf \
$(use_enable debug) \
--disable-werror
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}