You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild

43 lines
794 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
MY_P=${P/-ac}
DESCRIPTION="WMACPILoad based dockapp to monitor CPU temp and battery time on ACPI kernels"
HOMEPAGE="http://wmacpiload.tuxfamily.org/"
SRC_URI="http://wmacpiload.tuxfamily.org/download/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 x86"
IUSE="debug"
RDEPEND="x11-libs/libX11
x11-libs/libXt
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-acpi-segfault.patch"
"${FILESDIR}/${PN}-acpi-sys-temp-hwmon.patch"
"${FILESDIR}/${PN}-acpi-fix-battery-unit.patch"
)
src_prepare() {
default
eautoreconf
}
src_configure() {
econf $(use_enable debug)
}