You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmcliphist/wmcliphist-2.1-r3.ebuild

34 lines
639 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Dockable clipboard history application for Window Maker"
HOMEPAGE="https://www.dockapps.net/wmcliphist"
SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
S="${WORKDIR}/dockapps"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
RDEPEND="x11-libs/gtk+:3[X]"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_prepare() {
default
sed -e '/^PREFIX/s:=.*:=/usr:' \
-i Makefile || die
tc-export CC
}
src_install() {
default
newdoc ${PN}rc ${PN}rc.sample
}