You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-plugins/wmitime/wmitime-0.5-r1.ebuild

30 lines
658 B

# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Overglorified clock dockapp w/time, date, and internet time"
HOMEPAGE="https://www.dockapps.net/wmitime"
SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
RDEPEND=">=x11-libs/libdockapp-0.7:=
x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}"
src_compile() {
emake CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
emake DESTDIR="${D}" PREFIX=/usr install
einstalldocs
}