You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-terms/kitty-terminfo/kitty-terminfo-0.33.1.ebuild

24 lines
631 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
S="${WORKDIR}/kitty-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
RESTRICT="test" # intended to be ran on the full kitty package
BDEPEND="sys-libs/ncurses"
src_compile() { :; }
src_install() {
dodir /usr/share/terminfo
tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
}