You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5....

53 lines
1022 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit linux-info xdg-utils
DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
HOMEPAGE="
https://docs.xfce.org/panel-plugins/xfce4-battery-plugin/start
https://gitlab.xfce.org/panel-plugins/xfce4-battery-plugin/
"
SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm ~mips ~ppc ~riscv x86"
DEPEND="
>=dev-libs/glib-2.28.0:2
>=x11-libs/gtk+-3.16.0:3
>=xfce-base/libxfce4ui-4.14.0:=[gtk3(+)]
>=xfce-base/libxfce4util-4.14.0:=
>=xfce-base/xfce4-panel-4.14.0:=
"
RDEPEND="
${DEPEND}
"
BDEPEND="
dev-util/intltool
virtual/pkgconfig
"
pkg_setup() {
if use kernel_linux; then
CONFIG_CHECK="~ACPI_BATTERY"
linux-info_pkg_setup
fi
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}