You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4....

63 lines
1.1 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit xdg-utils
DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
HOMEPAGE="
https://docs.xfce.org/panel-plugins/xfce4-indicator-plugin/start
https://gitlab.xfce.org/panel-plugins/xfce4-indicator-plugin/
"
SRC_URI="
https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
DEPEND="
>=dev-libs/ayatana-ido-0.4.0
>=dev-libs/glib-2.26.0
>=dev-libs/libayatana-indicator-0.5.0:3
>=x11-libs/gtk+-3.18.0:3
x11-libs/libX11
>=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
>=xfce-base/libxfce4util-4.11.0:=
>=xfce-base/xfce4-panel-4.11.0:=
>=xfce-base/xfconf-4.13.0:=
"
RDEPEND="
${DEPEND}
"
BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
"
src_configure() {
local myconf=(
--enable-ido
)
econf "${myconf[@]}"
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {
xdg_icon_cache_update
xdg_desktop_database_update
}
pkg_postrm() {
xdg_icon_cache_update
xdg_desktop_database_update
}