You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/xfce-extra/xfce4-netload-plugin/xfce4-netload-plugin-1.4.1....

47 lines
891 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit xdg-utils
DESCRIPTION="A network load plug-in for the Xfce panel"
HOMEPAGE="
https://docs.xfce.org/panel-plugins/xfce4-netload-plugin/start
https://gitlab.xfce.org/panel-plugins/xfce4-netload-plugin/
"
SRC_URI="
https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
DEPEND="
>=dev-libs/glib-2.50.0
>=x11-libs/gtk+-3.22.0:3
>=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
>=xfce-base/xfce4-panel-4.12:=
"
RDEPEND="
${DEPEND}
"
BDEPEND="
dev-util/intltool
virtual/pkgconfig
"
src_install() {
default
find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}