You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/libintl-perl/files/libintl-perl-1.240.0-sanity...

52 lines
1.8 KiB

diff -ruN libintl-perl-1.24.orig/Makefile.PL libintl-perl-1.24/Makefile.PL
--- libintl-perl-1.24.orig/Makefile.PL 2015-04-03 15:28:12.000000000 +0200
+++ libintl-perl-1.24/Makefile.PL 2016-06-01 00:06:12.000000000 +0200
@@ -163,47 +163,6 @@
package MY;
-# FIXME: This is really a hack! Problem: Depending on the build system,
-# we may or may not build and install the XS version. If the XS version
-# is being built, the directory blib/arch will be populated, if it is
-# not being built, blib/arch will be empty. Unfortunately, if blib/arch
-# is not empty, *all* library files will be installed in the architecture
-# dependent locations, if it is empty, they will be installed in the
-# architecture independent tree.
-#
-# Unfortunately, ExtUtils::MakeMaker does not take care of uninstalling
-# files from previous installations. Consequently, we cannot determine
-# which version of the library will be loaded, since this depends on the
-# current value of @INC.
-#
-# The solution does not really make me happy. The Makefile will be patched,
-# so that instead of ExtUtils::Install a custom module MyInstall.pm will
-# be used. This custom module overwrites the subroutine that detects
-# whether a directory is empty in ExtUtils::Install, and will lie if that
-# directory happens to be "blib/arch". This little hack effectively disables
-# the annoying behavior of ExtUtils::Install (and I sincerely hope that
-# this is portable).
-sub libscan
-{
- my ($self, $file) = @_;
-
- return if 'MyInstall.pm' eq $file;
-
- $self->SUPER::libscan ($file);
-}
-
-sub tools_other
-{
- my $self = shift;
-
- my $fragment = $self->SUPER::tools_other (@_);
-
- $fragment =~ s/^MOD_INSTALL\s*=\s*(.*?)-MExtUtils::Install
- /MOD_INSTALL =$1-MMyInstall/msx;
-
- return $fragment;
-}
-
package main;
my $name = $0;