You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/tmux/files/tmux-2.3-flags.patch

16 lines
438 B

Makefile.am | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
--- tmux-2.3/Makefile.am
+++ tmux-2.3/Makefile.am
@@ -23,9 +23,8 @@
# Set flags for gcc.
if IS_GCC
-CFLAGS += -std=gnu99 -O2
+CFLAGS += -std=gnu99
if IS_DEBUG
-CFLAGS += -g
CFLAGS += -Wno-long-long -Wall -W -Wformat=2
CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare