You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/cpuid/files/cpuid-20170122-Makefile.patch

29 lines
1.3 KiB

diff -ru cpuid-20170122.orig/Makefile cpuid-20170122/Makefile
--- cpuid-20170122.orig/Makefile 2017-06-16 06:54:32.993875817 -0700
+++ cpuid-20170122/Makefile 2017-06-16 06:55:56.622875498 -0700
@@ -1,9 +1,3 @@
-CFLAGS+=-g
-CPPFLAGS?=
-LDFLAGS?=
-ifneq (,$(findstring arch=i386,$(CFLAGS)))
-CISA=-m32
-endif
CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
PACKAGE=cpuid
@@ -51,10 +45,10 @@
gzip < $< > $@
install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
- install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
+ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+ install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
+ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+ install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
clean:
rm -f $(PROG) $(PROG).i386 $(PROG).x86_64