You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system....

55 lines
1.3 KiB

* Fix parallel build
* Respect LDFLAGS
* Fix build with gmake 3.82
http://bugs.gentoo.org/show_bug.cgi?id=337479
--- a/Makefile.in
+++ b/Makefile.in
@@ -61,26 +61,26 @@
LIBDIR = lib/$(ARCH)/
CFLAGS = -Iinclude -Ifitssubs @MOTIF_CPPFLAGS@ @X_CFLAGS@ \
$(DEBUG) $(OSFLAGS) @CFLAGS@
-LIBS = @MOTIF_LIBS@ -lfitsLib
-LDFLAGS = @MOTIF_LDFLAGS@ @X_LIBS@ -L$(LIBDIR)
+LIBS = @MOTIF_LIBS@ @X_LIBS@ -L$(LIBDIR) -lfitsLib
+LDFLAGS = @LDFLAGS@ @MOTIF_LDFLAGS@
all: $(TARGETS)
# update source/object directory
srcupdate:
- cd src; $(MAKE)
+ $(MAKE) -C src
# update fitssubs source/object directory
fitsupdate:
- cd fitssubs; $(MAKE)
+ $(MAKE) -C fitssubs
# update fitssubs library directory
-libupdate:
- cd lib; $(MAKE) RANLIB="$(RANLIB)"
+libupdate: fitsupdate srcupdate
+ $(MAKE) RANLIB="$(RANLIB)" -C lib
# Link Obitview
-XFITSview: lib/$(ARCH)/libfitsLib.a src/*.c XFITSview.c
- $(CC) XFITSview.c -o XFITSview $(CFLAGS) src/*.o $(LDFLAGS) $(LIBS)
+XFITSview: XFITSview.c libupdate
+ $(CC) $(LDFLAGS) XFITSview.c -o XFITSview $(CFLAGS) src/*.o $(LIBS)
# make gzipped tar backup of directory
backup:
--- a/fitssubs/Makefile.in
+++ b/fitssubs/Makefile.in
@@ -69,7 +69,7 @@
# create library directory if needed
-../lib/$(ARCH): ../lib
+$(LIBDIR): ../lib
mkdir ../lib/$(ARCH)
clean: