You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/apbs/files/apbs-1.4.1-manip.patch

51 lines
1.4 KiB

apbs/CMakeLists.txt | 2 +-
apbs/tools/CMakeLists.txt | 4 ----
apbs/tools/mesh/CMakeLists.txt | 4 ++--
4 files changed, 5 insertions(+), 9 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8917fc4..5152008 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -293,7 +293,7 @@ option(ENABLE_FETK "Enable the finite element solver" OFF)
if(ENABLE_FETK)
message(STATUS "Checking for fetk components")
- set(FETK_ENALBED 1)
+ set(FETK_ENABLED 1)
list(APPEND APBS_LIBS "-lstdc++")
list(APPEND APBS_LIBS "-L${FETK_PATH}/lib")
diff --git a/tools/manip/CMakeLists.txt b/tools/manip/CMakeLists.txt
index 937dac7..5768cc5 100644
--- a/tools/manip/CMakeLists.txt
+++ b/tools/manip/CMakeLists.txt
@@ -4,9 +4,9 @@ set(LIBS "")
list(APPEND LIBS "apbs_generic")
list(APPEND LIBS "apbs_mg")
list(APPEND LIBS "apbs_pmgc")
-if(FETK_ENALBED)
+if(FETK_ENABLED)
list(APPEND LIBS "apbs_fem")
-endif(FETK_ENALBED)
+endif(FETK_ENABLED)
message(STATUS "libraries: ${LIBS}")
diff --git a/tools/mesh/CMakeLists.txt b/tools/mesh/CMakeLists.txt
index 1406377..6e6dfb9 100644
--- a/tools/mesh/CMakeLists.txt
+++ b/tools/mesh/CMakeLists.txt
@@ -4,9 +4,9 @@ set(LIBS "")
list(APPEND LIBS "apbs_generic")
list(APPEND LIBS "apbs_mg")
list(APPEND LIBS "apbs_pmgc")
-if(FETK_ENALBED)
+if(FETK_ENABLED)
list(APPEND LIBS "apbs_fem")
-endif(FETK_ENALBED)
+endif(FETK_ENABLED)
message(STATUS "libraries: ${LIBS}")