You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-firewall/ufw/files/ufw-0.34_pre805-shebang.patch

16 lines
675 B

--- a/setup.py
+++ b/setup.py
@@ -107,12 +107,6 @@ class Install(_install, object):
for f in [ script, manpage, manpage_f ]:
self.mkpath(os.path.dirname(f))
- # update the interpreter to that of the one the user specified for setup
- print("Updating staging/ufw to use %s" % (sys.executable))
- subprocess.call(["sed",
- "-i",
- "1s%^#.*python.*%#! /usr/bin/env " + sys.executable + "%g",
- 'staging/ufw'])
self.copy_file('staging/ufw', script)
self.copy_file('doc/ufw.8', manpage)
self.copy_file('doc/ufw-framework.8', manpage_f)