You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-plugins/nspluginwrapper/files/nspluginwrapper-1.4.4-compi...

13 lines
604 B

diff -ur nspluginwrapper-1.4.4.orig2//Makefile nspluginwrapper-1.4.4/Makefile
--- nspluginwrapper-1.4.4.orig2//Makefile 2011-07-14 11:56:52.674790086 -0400
+++ nspluginwrapper-1.4.4/Makefile 2011-07-14 12:01:00.281197722 -0400
@@ -337,7 +337,7 @@
@[ -d $(LSB_OBJ_DIR) ] || mkdir $(LSB_OBJ_DIR) > /dev/null 2>&1
$(LSB_OBJ_DIR)/%.o: $(LSB_SRC_DIR)/%.c $(LSB_OBJ_DIR)
- $(CC) $(CFLAGS_32) -nostdinc -fno-builtin -I. -I$(LSB_INC_DIR) -c $< -o $@
+ $(CC) $(CFLAGS_32) -nostdinc -fno-builtin -I. -I$(LSB_INC_DIR) -c -fno-stack-protector $< -o $@
$(LSB_OBJ_DIR)/%.a: $(LSB_OBJ_DIR)/%.o
$(AR) rc $@ $<