You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-arch/pure-sfv/files/pure-sfv-0.3-fix-build-syst...

24 lines
546 B

--- a/Makefile
+++ b/Makefile
@@ -54,18 +54,17 @@
VC_CRAP = pure-sfv.ncb pure-sfv.plg
-CFLAGS += -Wall -Werror -O2 -g -Wno-unused
+CFLAGS += -Wall -Wno-unused
INSTALL_PREFIX = /usr/local
INSTALL_PROGRAM = /usr/bin/install -c
all: pure-sfv
-CC = gcc
OBJ = ${SRCS:%.c=%.o}
pure-sfv: $(OBJ)
- $(CC) -lm -DVERSION=\"$(VERSION)\" $(CFLAGS) -o $(PROG) $(OBJ)
+ $(CC) -DVERSION=\"$(VERSION)\" $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o $(PROG) $(OBJ) -lm
PURIFY_OPTIONS=-follow-child-processes=yes -always-use-cache-dir=yes
PURIFY=purify