You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/rng-tools/files/rng-tools-6.3-jitterentropy...

37 lines
1.0 KiB

From c9f795da2dbeb0e85025f6264321aef1ba12059e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
Date: Fri, 6 Jul 2018 17:20:28 -0400
Subject: [PATCH] Makefile.am: use the libjitterentropy available on the system
---
Makefile.am | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index b80e9a0..5d33aaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,9 +2,7 @@
## Toplevel Makefile.am for rng-tools
##
if JITTER
- JSUBDIR = jitterentropy-library
- JSUBLIB = ./jitterentropy-library/libjitterentropy.a
- AM_CPPFLAGS = -I./jitterentropy-library
+ jitterentropy_LIBS = -ljitterentropy
endif
SUBDIRS = contrib tests $(JSUBDIR)
@@ -33,7 +31,7 @@ if JITTER
rngd_SOURCES += rngd_jitter.c
endif
-rngd_LDADD = librngd.a -lsysfs $(JSUBLIB) ${libcurl_LIBS} ${libxml2_LIBS} ${openssl_LIBS}
+rngd_LDADD = librngd.a -lsysfs $(jitterentropy_LIBS) ${libcurl_LIBS} ${libxml2_LIBS} ${openssl_LIBS}
rngd_CFLAGS = ${libxml2_CFLAGS} ${openssl_CFLAGS}
--
2.17.0