gentoo-overlay/net-libs/hubbub/files/hubbub-0.1.2-glibc-2.20.patch

17 lines
621 B
Diff

--- work/hubbub-0.1.2/Makefile
+++ work/hubbub-0.1.2/Makefile
@@ -13,13 +13,7 @@
WARNFLAGS := -Wall -W -Wundef -Wpointer-arith -Wcast-align \
-Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes \
-Wmissing-declarations -Wnested-externs -pedantic
-# BeOS/Haiku/AmigaOS have standard library errors that issue warnings.
-ifneq ($(TARGET),beos)
- ifneq ($(TARGET),amiga)
- WARNFLAGS := $(WARNFLAGS) -Werror
- endif
-endif
-CFLAGS := -D_BSD_SOURCE -I$(CURDIR)/include/ \
+CFLAGS := -D_DEFAULT -I$(CURDIR)/include/ \
-I$(CURDIR)/src $(WARNFLAGS) $(CFLAGS)
ifneq ($(GCCVER),2)
CFLAGS := $(CFLAGS) -std=c99