You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-chemistry/apbs/files/apbs-1.3-python.patch

23 lines
985 B

diff --git a/configure.ac b/configure.ac
index 31a0053..7301f0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -585,6 +585,7 @@ if test x"$enable_python" != "xno"; then
PY_SHARED="-shared"
CC="${CC} -fPIC"
F77="${F77} -fPIC"
+ PY_LDFLAGS="-lpython$PY_VERSION"
;;
irix*)
PY_SHARED="-shared"
diff --git a/tools/python/Makefile.am b/tools/python/Makefile.am
index 431640c..2c1fbea 100644
--- a/tools/python/Makefile.am
+++ b/tools/python/Makefile.am
@@ -16,4 +16,4 @@ SUBDIRS = vgrid
noinst_PROGRAMS = _apbslib.so
_apbslib_so_SOURCES = apbslib.c
_apbslib_so_LINK = $(PY_CC) $(PY_LINKFLAGS) $(LDFLAGS) -o $@ $(PY_SHARED)
-_apbslib_so_LDADD = ${top_builddir}/bin/.libs/libapbsmainroutines.a ${top_builddir}/src/aaa_lib/.libs/libapbs.a $(PY_LDFLAGS) ${z_lib}
+_apbslib_so_LDADD = ${top_builddir}/bin/.libs/libapbsmainroutines.a ${top_builddir}/src/aaa_lib/.libs/libapbs.a $(PY_LDFLAGS) ${z_lib} @OPENMP_LIBS@ @maloc_lib@ @mc_lib@