You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/realpath/files/realpath-1.15-prefix.patch

40 lines
1.4 KiB

diff --git a/common.mk b/common.mk
index 2443a40..0a342ee 100644
--- a/common.mk
+++ b/common.mk
@@ -8,17 +8,19 @@ override TOPDIR := $(dir $(call getCurrentMakefileName))
override PACKAGE := realpath
-PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
+#PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
+
+SHELL := @GENTOO_PORTAGE_EPREFIX@/bin/bash
# build abstraction
-install_file := install -p -o root -g root -m 644
-install_script := install -p -o root -g root -m 755
-install_dir := install -d -o root -g root -m 755
+install_file := install -p -m 644
+install_script := install -p -m 755
+install_dir := install -d -m 755
install_link := ln -sf
compress := gzip -9f
-prefix := /usr
-etcdir := /etc/$(PACKAGE)
+prefix := @GENTOO_PORTAGE_EPREFIX@/usr
+etcdir := @GENTOO_PORTAGE_EPREFIX@/etc/$(PACKAGE)
bindir := $(prefix)/bin
sbindir := $(prefix)/sbin
mandir := $(prefix)/share/man
@@ -33,7 +35,7 @@ webdocrootdir := /var/www
webcgidir := $(prefix)/lib/cgi-bin
applicationsdir := $(prefix)/share/applications
-PERL := /usr/bin/perl
+PERL := @GENTOO_PORTAGE_EPREFIX@/usr/bin/perl
CC ?= gcc
CFLAGS += -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
LDFLAGS +=