58 lines
No EOL
2.1 KiB
Diff
58 lines
No EOL
2.1 KiB
Diff
From 18917f7fd3160afe06019f4b6234aeb78a3fdb4e Mon Sep 17 00:00:00 2001
|
|
From: Ross Burton <ross.burton@intel.com>
|
|
Date: Tue, 19 Nov 2013 16:00:29 +0000
|
|
Subject: [PATCH] configure: add option to enable/disable use of GTK+
|
|
|
|
Distro packagers like predictability and automatically detected optional
|
|
dependencies are not predicable. Add a --with-gtk3 option (default to "auto")
|
|
for forcibly controlling whether GTK+ will be used or not.
|
|
|
|
Signed-off-by: Ross Burton <ross.burton@intel.com>
|
|
|
|
https://bugzilla.gnome.org/show_bug.cgi?id=712693
|
|
---
|
|
configure.in | 17 +++++++++++------
|
|
1 file changed, 11 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/configure.in b/configure.in
|
|
index f7a89dc..1498f72 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -119,17 +119,22 @@ AC_CHECK_FUNCS(strtok_r)
|
|
# GTK
|
|
# ===========================================================================
|
|
|
|
-PKG_CHECK_MODULES([GTK3],[gtk+-3.0 >= $GTK3_REQUIRED],[have_gtk_3=yes],[have_gtk_3=no])
|
|
-
|
|
GTK3_BINARY_VERSION=
|
|
|
|
-if test "$have_gtk_3" = "yes"; then
|
|
- GTK3_BINARY_VERSION="`$PKG_CONFIG --variable=gtk_binary_version gtk+-3.0`"
|
|
+AC_MSG_CHECKING([whether to use GTK+ 3])
|
|
+AC_ARG_WITH([gtk3],
|
|
+ [AS_HELP_STRING([--without-gtk3],[Don't build GTK+3 tools (default=auto)])],
|
|
+ [],[PKG_CHECK_EXISTS([gtk+-3.0 >= $GTK3_REQUIRED],[with_gtk3=yes],[with_gtk3=no])])
|
|
+AC_MSG_RESULT([$with_gtk3])
|
|
+
|
|
+if test "$with_gtk3" = "yes"; then
|
|
+ PKG_CHECK_MODULES(GTK3, [gtk+-3.0 >= $GTK3_REQUIRED])
|
|
+ GTK3_BINARY_VERSION="`$PKG_CONFIG --variable=gtk_binary_version gtk+-3.0`"
|
|
fi
|
|
|
|
AC_SUBST([GTK3_BINARY_VERSION])
|
|
|
|
-AM_CONDITIONAL([HAVE_GTK_3],[test "$have_gtk_3" = "yes"])
|
|
+AM_CONDITIONAL([HAVE_GTK_3],[test "$with_gtk3" = "yes"])
|
|
|
|
dnl ===========================================================================
|
|
dnl GDK-Pixbuf SVG loader
|
|
@@ -305,6 +310,6 @@ librsvg-$VERSION
|
|
Build introspectable bindings: ${found_introspection}
|
|
Build Vala bindings: ${enable_vala}
|
|
Build GdkPixbuf loader: ${enable_pixbuf_loader}
|
|
- GTK 3.0: ${have_gtk_3}
|
|
+ GTK 3.0: ${with_gtk3}
|
|
Build miscellaenous tools: ${build_misc_tools}
|
|
"
|
|
--
|
|
1.7.10.4
|