You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-office/gtg/files/gtg-0.3.1-locales.patch

21 lines
584 B

Do not install unwanted locales.
--- a/setup.py 2014-11-01 11:21:49.679613605 +0100
+++ b/setup.py 2014-11-01 11:26:36.305719135 +0100
@@ -101,9 +101,15 @@
PO_DIR = 'po'
MO_DIR = os.path.join('build', 'po')
+LINGUAS = os.environ.get('LINGUAS', '*').split(' ')
for po in glob.glob(os.path.join(PO_DIR, '*.po')):
lang = os.path.basename(po[:-3])
+
+ # Skip unwanted locales
+ if lang not in LINGUAS and '*' not in LINGUAS:
+ continue
+
mo = os.path.join(MO_DIR, lang, 'gtg.mo')
target_dir = os.path.dirname(mo)
if not os.path.isdir(target_dir):