You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/postgresql/files/postgresql-9.2-no-server.patch

144 lines
4.1 KiB

diff -Naur a/contrib/Makefile b/contrib/Makefile
--- a/contrib/Makefile 2012-05-10 18:35:09.000000000 -0400
+++ b/contrib/Makefile 2012-05-20 09:33:47.892622992 -0400
@@ -5,58 +5,10 @@
include $(top_builddir)/src/Makefile.global
SUBDIRS = \
- adminpack \
- auth_delay \
- auto_explain \
- btree_gin \
- btree_gist \
- chkpass \
- citext \
- cube \
- dblink \
- dict_int \
- dict_xsyn \
- dummy_seclabel \
- earthdistance \
- file_fdw \
- fuzzystrmatch \
- hstore \
- intagg \
- intarray \
- isn \
- lo \
- ltree \
oid2name \
- pageinspect \
- passwordcheck \
- pg_archivecleanup \
- pg_buffercache \
- pg_freespacemap \
- pg_standby \
- pg_stat_statements \
- pg_test_fsync \
- pg_test_timing \
- pg_trgm \
- pg_upgrade \
- pg_upgrade_support \
pgbench \
- pgcrypto \
- pgrowlocks \
- pgstattuple \
- seg \
- spi \
- tablefunc \
- tcn \
- test_parser \
- tsearch2 \
- unaccent \
vacuumlo
-ifeq ($(with_openssl),yes)
-SUBDIRS += sslinfo
-else
-ALWAYS_SUBDIRS += sslinfo
-endif
ifeq ($(with_ossp_uuid),yes)
SUBDIRS += uuid-ossp
diff -Naur a/src/backend/Makefile b/src/backend/Makefile
--- a/src/backend/Makefile 2012-05-10 18:35:09.000000000 -0400
+++ b/src/backend/Makefile 2012-05-20 09:36:24.446654842 -0400
@@ -45,7 +45,7 @@
##########################################################################
-all: submake-libpgport submake-schemapg postgres $(POSTGRES_IMP)
+all: someheaders
ifneq ($(PORTNAME), cygwin)
ifneq ($(PORTNAME), win32)
@@ -114,7 +114,7 @@
endif # aix
# Update the commonly used headers before building the subdirectories
-$(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/catalog/schemapg.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/errcodes.h $(top_builddir)/src/include/utils/probes.h
+someheaders $(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/catalog/schemapg.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/errcodes.h $(top_builddir)/src/include/utils/probes.h
# run this unconditionally to avoid needing to know its dependencies here:
submake-schemapg:
@@ -207,23 +207,7 @@
##########################################################################
-install: all installdirs install-bin
-ifeq ($(PORTNAME), cygwin)
-ifeq ($(MAKE_DLL), true)
- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
-endif
-endif
-ifeq ($(PORTNAME), win32)
-ifeq ($(MAKE_DLL), true)
- $(INSTALL_DATA) libpostgres.a '$(DESTDIR)$(libdir)/libpostgres.a'
-endif
-endif
- $(MAKE) -C catalog install-data
- $(MAKE) -C tsearch install-data
- $(INSTALL_DATA) $(srcdir)/libpq/pg_hba.conf.sample '$(DESTDIR)$(datadir)/pg_hba.conf.sample'
- $(INSTALL_DATA) $(srcdir)/libpq/pg_ident.conf.sample '$(DESTDIR)$(datadir)/pg_ident.conf.sample'
- $(INSTALL_DATA) $(srcdir)/utils/misc/postgresql.conf.sample '$(DESTDIR)$(datadir)/postgresql.conf.sample'
- $(INSTALL_DATA) $(srcdir)/access/transam/recovery.conf.sample '$(DESTDIR)$(datadir)/recovery.conf.sample'
+install:
install-bin: postgres $(POSTGRES_IMP) installdirs
$(INSTALL_PROGRAM) postgres$(X) '$(DESTDIR)$(bindir)/postgres$(X)'
diff -Naur a/src/bin/Makefile b/src/bin/Makefile
--- a/src/bin/Makefile 2012-05-10 18:35:09.000000000 -0400
+++ b/src/bin/Makefile 2012-05-20 09:41:18.489958216 -0400
@@ -13,8 +13,7 @@
top_builddir = ../..
include $(top_builddir)/src/Makefile.global
-SUBDIRS = initdb pg_ctl pg_dump \
- psql scripts pg_config pg_controldata pg_resetxlog pg_basebackup
+SUBDIRS = pg_dump psql scripts pg_config
ifeq ($(PORTNAME), win32)
SUBDIRS += pgevent
diff -Naur a/src/Makefile b/src/Makefile
--- a/src/Makefile 2012-05-10 18:35:09.000000000 -0400
+++ b/src/Makefile 2012-05-20 09:40:13.532774840 -0400
@@ -14,17 +14,11 @@
SUBDIRS = \
port \
- timezone \
backend \
- backend/utils/mb/conversion_procs \
- backend/snowball \
include \
interfaces \
- backend/replication/libpqwalreceiver \
bin \
- pl \
- makefiles \
- test/regress
+ makefiles
# There are too many interdependencies between the subdirectories, so
# don't attempt parallel make here.