You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/color/files/1.2-ldflags.patch

24 lines
404 B

diff --git a/Makefile b/Makefile
index 79c5b33..452e091 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-CC = cc
+CC ?= cc
#CFLAGS = -W -Wall -O2 -g
INCLUDE = $(wildcard *.h)
OBJS = color.o
@@ -6,8 +6,11 @@ EXE = color
all: $(EXE)
+OBJS: color.c
+ $(CC) $(CFLAGS) -c $^ $@
+
$(EXE): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $^
+ $(CC) $(LDFLAGS) -o $@ $^
install: all
cp $(EXE) /usr/local/bin