You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.p...

15 lines
421 B

--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,9 @@
-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
all: hexcompare
hexcompare: main.c gui.c
- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
+ $(CC) $(CFLAGS) `${PKG_CONFIG} --cflags ncurses` -o hexcompare main.c gui.c `${PKG_CONFIG} --libs ncurses`
clean:
rm -f *.o