48 lines
1.6 KiB
Diff
48 lines
1.6 KiB
Diff
diff --git a/Makefile.am b/Makefile.am
|
|
index 2865fb7..75cbd45 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -6,7 +6,7 @@ libname = libonig.la
|
|
ACLOCAL_AMFLAGS = -I m4
|
|
#AM_CFLAGS = -DNOT_RUBY
|
|
AM_CFLAGS =
|
|
-INCLUDES = -I$(top_srcdir) -I$(includedir)
|
|
+INCLUDES = -I$(top_srcdir)
|
|
|
|
SUBDIRS = . sample
|
|
|
|
diff --git a/configure.in b/configure.in
|
|
index 1e21f96..51b56d8 100644
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -25,7 +25,7 @@ dnl check for COMBINATION_EXPLOSION
|
|
AC_ARG_ENABLE(combination-explosion-check,
|
|
[ --enable-combination-explosion-check enable combination explosion check],
|
|
[comb_expl_check=$enableval])
|
|
-if test "${comb_expl_check}" = yes; then
|
|
+if test "x${comb_expl_check}" = xyes; then
|
|
AC_DEFINE(USE_COMBINATION_EXPLOSION_CHECK,1,[Define if combination explosion check])
|
|
fi
|
|
|
|
@@ -33,7 +33,7 @@ dnl check for CRNL_AS_LINE_TERMINATOR
|
|
AC_ARG_ENABLE(crnl-as-line-terminator,
|
|
[ --enable-crnl-as-line-terminator enable CR+NL as line terminator],
|
|
[crnl_as_line_terminator=$enableval])
|
|
-if test "${crnl_as_line_terminator}" = yes; then
|
|
+if test "x${crnl_as_line_terminator}" = xyes; then
|
|
AC_DEFINE(USE_CRNL_AS_LINE_TERMINATOR,1,[Define if enable CR+NL as line terminator])
|
|
fi
|
|
|
|
diff --git a/sample/Makefile.am b/sample/Makefile.am
|
|
index af33057..347af94 100644
|
|
--- a/sample/Makefile.am
|
|
+++ b/sample/Makefile.am
|
|
@@ -2,7 +2,7 @@ noinst_PROGRAMS = encode listcap names posix simple sql syntax crnl
|
|
|
|
libname = $(top_builddir)/libonig.la
|
|
LDADD = $(libname)
|
|
-INCLUDES = -I$(top_srcdir) -I$(includedir)
|
|
+INCLUDES = -I$(top_srcdir)
|
|
|
|
encode_SOURCES = encode.c
|
|
listcap_SOURCES = listcap.c
|