gentoo-overlay/dev-libs/oniguruma/files/oniguruma-gentoo.patch

49 lines
1.5 KiB
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,7 @@
AC_ARG_ENABLE(combination-explosion-check,
[ --enable-combination-explosion-check enable combination explosion check],
[comb_expl_check=$enableval])
-if test "${comb_expl_check}" = yes; then
+if test "x${comb_expl_check}" = xyes; then
AC_DEFINE(USE_COMBINATION_EXPLOSION_CHECK,1,[Define if combination explosion check])
fi
@@ -26,7 +26,7 @@
AC_ARG_ENABLE(crnl-as-line-terminator,
[ --enable-crnl-as-line-terminator enable CR+NL as line terminator],
[crnl_as_line_terminator=$enableval])
-if test "${crnl_as_line_terminator}" = yes; then
+if test "x${crnl_as_line_terminator}" = xyes; then
AC_DEFINE(USE_CRNL_AS_LINE_TERMINATOR,1,[Define if enable CR+NL as line terminator])
fi
--- a/sample/Makefile.am
+++ b/sample/Makefile.am
@@ -1,10 +1,10 @@
#noinst_PROGRAMS = encode listcap names posix simple sql syntax crnl
-lib_onig = ../src/libonig.la
+lib_onig = $(top_builddir)/src/libonig.la
LDADD = $(lib_onig)
AM_LDFLAGS = -L$(prefix)/lib
-AM_CPPFLAGS = -I../src -I$(includedir)
+AM_CPPFLAGS = -I$(top_srcdir)/src
TESTS = encode listcap names posix simple sql syntax user_property bug_fix
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,9 +1,9 @@
## Makefile.am for Oniguruma
-lib_onig = ../src/libonig.la
+lib_onig = $(top_builddir)/src/libonig.la
AM_LDFLAGS = -L$(prefix)/lib
AM_CFLAGS =
-AM_CPPFLAGS = -I../src -I$(includedir)
+AM_CPPFLAGS = -I$(top_srcdir)/src
TESTS = testc testp testcu