You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-cdr/brasero/files/0001-Fix-build-link-libbras...

50 lines
1.4 KiB

From 8410d2f7cddb6f5d102f9a1fa5d60ce50ca08696 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Fr=C3=A9d=C3=A9ric=20P=C3=A9ters?= <fpeters@0d.be>
Date: Wed, 19 Sep 2012 11:38:53 +0200
Subject: [PATCH] Fix build, link libbrasero-burn against libm (for ceil(3))
---
configure.in | 4 ++++
libbrasero-burn/Makefile.am | 3 ++-
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/configure.in b/configure.in
index 4ba113c..9b0df2d 100644
--- a/configure.in
+++ b/configure.in
@@ -138,6 +138,7 @@ dnl ***************** LARGE FILE SUPPORT ***********************
AC_SYS_LARGEFILE
dnl ********** Required libraries **********************
+
GLIB_REQUIRED=2.29.14
GTHREAD_REQUIRED=2.6.0
GMODULE_REQUIRED=2.6.0
@@ -209,6 +210,9 @@ PKG_CHECK_MODULES(BRASERO_SM,
AC_SUBST(BRASERO_SM_CFLAGS)
AC_SUBST(BRASERO_SM_LIBS)
+AC_CHECK_LIBM
+AC_SUBST(LIBM)
+
#
# GTK+ stuff (taken and adapted from empathy)
#
diff --git a/libbrasero-burn/Makefile.am b/libbrasero-burn/Makefile.am
index 2e64449..3c723ce 100644
--- a/libbrasero-burn/Makefile.am
+++ b/libbrasero-burn/Makefile.am
@@ -67,7 +67,8 @@ libbrasero_burn3_la_LIBADD = \
$(BRASERO_GTK_LIBS) \
$(BRASERO_GSTREAMER_LIBS) \
$(BRASERO_LIBNOTIFY_LIBS) \
- $(BRASERO_CANBERRA_LIBS)
+ $(BRASERO_CANBERRA_LIBS) \
+ $(LIBM)
libbrasero_burn3_la_LDFLAGS = \
-version-info $(LIBBRASERO_LT_VERSION) \
--
1.8.0.2