You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/docker-compose/files/docker-compose-1.24.0-setup...

59 lines
1.7 KiB

From 981faad5f67a843f2b6c44f40be4dc8d2c5156c7 Mon Sep 17 00:00:00 2001
From: Sebastian Pipping <sebastian@pipping.org>
Date: Sat, 11 May 2019 00:32:22 +0200
Subject: [PATCH] setup.py: Drop generic upper version boundaries
---
setup.py | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/setup.py b/setup.py
index 8371cc7..b9e5a80 100644
--- a/setup.py
+++ b/setup.py
@@ -30,16 +30,16 @@ def find_version(*file_paths):
install_requires = [
- 'cached-property >= 1.2.0, < 2',
- 'docopt >= 0.6.1, < 0.7',
- 'PyYAML >= 3.10, < 4.3',
- 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
- 'texttable >= 0.9.0, < 0.10',
- 'websocket-client >= 0.32.0, < 1.0',
- 'docker[ssh] >= 3.7.0, < 4.0',
- 'dockerpty >= 0.4.1, < 0.5',
- 'six >= 1.3.0, < 2',
- 'jsonschema >= 2.5.1, < 3',
+ 'cached-property >= 1.2.0',
+ 'docopt >= 0.6.1',
+ 'PyYAML >= 3.10',
+ 'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
+ 'texttable >= 0.9.0',
+ 'websocket-client >= 0.32.0',
+ 'docker[ssh] >= 3.7.0',
+ 'dockerpty >= 0.4.1',
+ 'six >= 1.3.0',
+ 'jsonschema >= 2.5.1',
]
@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
tests_require.append('mock >= 1.0.1')
extras_require = {
- ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
+ ':python_version < "3.4"': ['enum34 >= 1.0.4'],
':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
':python_version < "3.3"': ['ipaddress >= 1.0.16'],
- ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
+ ':sys_platform == "win32"': ['colorama >= 0.4'],
+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
}
--
2.21.0