You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/dbmeasure/files/dbmeasure-0.0.20100217-make...

24 lines
695 B

We drop the -g for debug output but we keep the -O0, as we don't want GCC
to optimize out some critical math.
--- a/Makefile
+++ b/Makefile
@@ -1,13 +1,13 @@
-CFLAGS=-Wextra -Wall -O0 -g -pipe `pkg-config --cflags alsa`
-LIBS=`pkg-config --libs alsa` -lm
+CFLAGS+=-Wextra -Wall -O0 $(shell $(PKG_CONFIG) --cflags alsa)
+LIBS=-lm $(shell $(PKG_CONFIG) --libs alsa)
all: dbmeasure dbverify
dbmeasure: dbmeasure.o
- $(CC) -o dbmeasure $^ $(CFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o dbmeasure $^ $(LIBS)
dbverify: dbverify.o
- $(CC) -o dbverify $^ $(CFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o dbverify $^ $(LIBS)
clean:
rm -f *.o dbmeasure dbverify