You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/timemachine/files/timemachine-0.3.4-underlink...

25 lines
680 B

diff --git a/configure.ac b/configure.ac
index dfc8df7..0208487 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT(configure.in)
+AC_INIT(configure.ac)
AM_INIT_AUTOMAKE(timemachine, 0.3.4)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
@@ -10,6 +10,11 @@ AC_PROG_CC
AM_PROG_CC_STDC
AC_HEADER_STDC
+dnl Check for libm for log10()
+AC_SEARCH_LIBS([log10], [m], [], [
+ AC_MSG_ERROR([unable to find the log10() function])
+])
+
PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0])
PKG_CHECK_MODULES(JACK, [jack >= 0.80.0])
PKG_CHECK_MODULES(LIBLO, liblo >= 0.24, LO_FOUND="yes", LO_FOUND="no")