You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/poco/files/1.4.6_p1-gentoo.patch

75 lines
3.1 KiB

diff -Nur poco-1.4.5-all_old/components poco-1.4.5-all/components
--- poco-1.4.5-all_old/components 2012-11-18 16:56:59.000000000 +0100
+++ poco-1.4.5-all/components 2012-12-06 12:29:07.779546771 +0100
@@ -1,14 +1,8 @@
-CppUnit
Foundation
XML
Util
Net
-Crypto
-NetSSL_OpenSSL
Data
-Data/SQLite
-Data/ODBC
-Data/MySQL
Zip
PageCompiler
PageCompiler/File2Page
diff -Nur poco-1.4.5-all_old/Data/ODBC/ODBC.make poco-1.4.5-all/Data/ODBC/ODBC.make
--- poco-1.4.5-all_old/Data/ODBC/ODBC.make 2012-11-18 16:56:57.000000000 +0100
+++ poco-1.4.5-all/Data/ODBC/ODBC.make 2012-12-06 12:29:07.779546771 +0100
@@ -14,9 +14,9 @@
ifeq (0, $(shell test -d /usr/lib/$(OSARCH)-linux-gnu; echo $$?))
ODBCLIBDIR = /usr/lib/$(OSARCH)-linux-gnu
else ifeq (0, $(shell test -d /usr/lib64; echo $$?))
-ODBCLIBDIR = /usr/lib64
+ODBCLIBDIR = /usr/$(LIBDIR)
else
-ODBCLIBDIR = /usr/lib
+ODBCLIBDIR = /usr/$(LIBDIR)
endif
endif
@@ -39,10 +39,10 @@
CXXFLAGS += -DODBCVER=0x0300 -DNOMINMAX
# CYGWIN platform has its own ODBC library in /lib/w32api
SYSLIBS += -L/lib/w32api -lodbc32 -lodbccp32
-else ifeq (0, $(shell test -e $(ODBCLIBDIR)/libodbc$(LIBLINKEXT); echo $$?))
+else ifeq (unixodbc, $(GENTOO_ODBC))
SYSLIBS += -lodbc -lodbcinst
COMMONFLAGS += -DPOCO_UNIXODBC
-else ifeq (0, $(shell test -e $(ODBCLIBDIR)/libiodbc$(LIBLINKEXT); echo $$?))
+else ifeq (unixodbc, $(GENTOO_ODBC))
SYSLIBS += -liodbc -liodbcinst
COMMONFLAGS += -DPOCO_IODBC -I/usr/include/iodbc
else
diff -Nur poco-1.4.5-all_old/Makefile poco-1.4.5-all/Makefile
--- poco-1.4.5-all_old/Makefile 2012-11-18 16:57:00.000000000 +0100
+++ poco-1.4.5-all/Makefile 2012-12-06 12:29:07.779546771 +0100
@@ -33,7 +33,7 @@
install: libexecs
mkdir -p $(INSTALLDIR)/include/Poco
- mkdir -p $(INSTALLDIR)/lib
+ mkdir -p $(INSTALLDIR)/$(LIBDIR)
mkdir -p $(INSTALLDIR)/bin
for comp in $(COMPONENTS) ; do \
if [ -d "$(POCO_BASE)/$$comp/include" ] ; then \
@@ -43,11 +43,11 @@
find $(POCO_BUILD)/$$comp/bin -perm -700 -type f -exec cp -f {} $(INSTALLDIR)/bin \; ; \
fi ; \
done
- find $(POCO_BUILD)/lib -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/lib \;
- find $(POCO_BUILD)/lib -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/lib \;
+ find $(POCO_BUILD)/$(LIBDIR) -name "libPoco*" -type f -exec cp -f {} $(INSTALLDIR)/$(LIBDIR) \;
+ find $(POCO_BUILD)/$(LIBDIR) -name "libPoco*" -type l -exec cp -Rf {} $(INSTALLDIR)/$(LIBDIR) \;
-libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Crypto-libexec NetSSL_OpenSSL-libexec Data-libexec Data/SQLite-libexec Data/ODBC-libexec Data/MySQL-libexec Zip-libexec PageCompiler-libexec PageCompiler/File2Page-libexec
-tests = Foundation-tests XML-tests Util-tests Net-tests Crypto-tests NetSSL_OpenSSL-tests Data-tests Data/SQLite-tests Data/ODBC-tests Data/MySQL-tests Zip-tests
+libexecs = Foundation-libexec XML-libexec Util-libexec Net-libexec Data-libexec Zip-libexec PageCompiler-libexec
+tests = Foundation-tests XML-tests Util-tests Net-tests Data-tests Zip-tests
samples = Foundation-samples XML-samples Util-samples Net-samples Crypto-samples NetSSL_OpenSSL-samples Data-samples Zip-samples PageCompiler-samples
.PHONY: $(libexecs)