You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-games/guichan/files/guichan-0.8.2-as-needed.patch

20 lines
553 B

--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = widgets @GUICHAN_EXTRADIRS@ hge openlayer contrib
+SUBDIRS = widgets . @GUICHAN_EXTRADIRS@ hge openlayer contrib
INCLUDES = -I$(top_srcdir)/include
--- a/src/sdl/Makefile.am
+++ b/src/sdl/Makefile.am
@@ -6,6 +6,8 @@
libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+libguichan_sdl_la_LIBADD = -lSDL_image -L$(top_srcdir)/src -lguichan
+
libguichan_sdl_la_SOURCES = \
sdl.cpp \
sdlgraphics.cpp \