You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-cdr/gaffitter/files/gaffitter-0.6.0-fix-build-s...

33 lines
704 B

--- a/src/Makefile
+++ b/src/Makefile
@@ -6,28 +6,14 @@
optimizers/BestFit.cc optimizers/Split.cc \
util/CmdLineParser.cc
-INCLUDES = -I/usr/local/include -I.
-CXX = g++
-CXXFLAGS = -O3 -Wno-long-long $(INCLUDES)
-LIBPATH =
-LIBS =
-LDFLAGS = $(LIBPATH) $(LIBS)
-
###########################################################################
OBJS = $(CPPFILES:.cc=.o)
-.SUFFIXES: .o .cc
-
-.cc.o:
- @echo $<:
- $(CXX) $(CXXFLAGS) -c $*.cc -o $*.o
-
default: gaffitter
-gaffitter: $(OBJS) gaffitter.cc Params.h
- $(CXX) $(CXXFLAGS) $@.cc $(OBJS) -o $@ $(LDFLAGS)
+gaffitter: $(OBJS)
###########################################################################
objs: $(OBJS)