You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/lxc/files/lxc-1.0.11-bash-completion....

28 lines
924 B

diff --git a/config/bash/lxc.in b/config/bash/lxc.in
index 344d5cb2..f051eaae 100644
--- a/config/bash/lxc.in
+++ b/config/bash/lxc.in
@@ -1,4 +1,3 @@
-_have lxc-start && {
_lxc_names() {
COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
}
@@ -100,4 +99,3 @@ _have lxc-start && {
complete -o default -F _lxc_generic_o lxc-clone
complete -o default -F _lxc_generic_o lxc-start-ephemeral
-}
diff --git a/configure.ac b/configure.ac
index 2ea88c19..f52d772a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -429,7 +429,7 @@ AM_CONDITIONAL([ENABLE_BASH], [test "x$enable_bash" = "xyes"])
AM_COND_IF([ENABLE_BASH],
[AC_MSG_CHECKING([bash completion directory])
PKG_CHECK_VAR(bashcompdir, [bash-completion], [completionsdir], ,
- bashcompdir="${sysconfdir}/bash_completion.d")
+ bashcompdir="$datadir/bash-completion/completions")
AC_MSG_RESULT([$bashcompdir])
AC_SUBST(bashcompdir)
])