You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-base/gdm/files/gdm-3.22.1-pam-module-dir.p...

53 lines
1.5 KiB

From 4fc9023bb86689f1391651fa744d9e63ee1d7bbc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
Date: Mon, 21 Nov 2016 08:18:32 +0100
Subject: [PATCH] pam_gdm: allow setting pam module dir at configure time
Code taken almost verbatim from gnome-keyring.
---
configure.ac | 10 +++++++++-
pam_gdm/Makefile.am | 2 +-
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index dd98992..e0074dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -476,7 +476,7 @@ dnl ---------------------------------------------------------------------------
dnl - Check for PAM stuff
dnl ---------------------------------------------------------------------------
-dnl PAM prefix
+dnl PAM prefix (configuration files)
withval=""
AC_ARG_WITH(pam-prefix,
AS_HELP_STRING([--with-pam-prefix=<prefix>],
@@ -492,6 +492,14 @@ else
fi
AC_SUBST(PAM_PREFIX)
+dnl PAM dir (dynamic modules)
+AC_ARG_WITH([pam-dir],
+ [AC_HELP_STRING([--with-pam-dir=DIR],
+ [directory to install pam modules in])],
+ [], [with_pam_dir='${libdir}/security'])
+PAM_DEST_DIR="$with_pam_dir"
+AC_SUBST(PAM_DEST_DIR)
+
have_pam=no
AC_CHECK_LIB(pam, pam_start, have_pam=yes)
diff --git a/pam_gdm/Makefile.am b/pam_gdm/Makefile.am
index 61d672b..980b31c 100644
--- a/pam_gdm/Makefile.am
+++ b/pam_gdm/Makefile.am
@@ -36,4 +36,4 @@ pam_gdm_LTLIBRARIES = \
pam_gdm.la \
$(END_OF_LIST)
-pam_gdmdir = $(libdir)/security
+pam_gdmdir = $(PAM_DEST_DIR)
--
2.10.2