You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/qdbm/files/qdbm-perl-runpath-vendor.diff

23 lines
1.0 KiB

diff -ur qdbm-1.8.62.orig/perl/Makefile.in qdbm-1.8.62/perl/Makefile.in
--- qdbm-1.8.62.orig/perl/Makefile.in
+++ qdbm-1.8.62/perl/Makefile.in
@@ -42,15 +42,15 @@
all :
cd depot && [ -f Makefile ] || \
$(RUNENV) perl Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; \
+ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS=vendor ; \
$(RUNENV) make
cd curia && [ -f Makefile ] || \
$(RUNENV) perl Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; \
+ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS=vendor ; \
$(RUNENV) make
cd villa && [ -f Makefile ] || \
$(RUNENV) perl Makefile.PL CC="$(CC)" INC="$(INC)" OPTIMIZE="$(OPTIMIZE)" \
- LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" ; \
+ LD="$(LD)" LIBS="$(LIBS)" PREFIX="$(prefix)" INSTALLDIRS=vendor ; \
$(RUNENV) make
@printf '\n'
@printf '#================================================================\n'