You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pip/files/pip-21.0-no-coverage.patch

54 lines
2.0 KiB

From 7f61ba983025cbfab7b7b810b13f1a89cb503568 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Wed, 29 Jul 2020 07:42:25 +0200
Subject: [PATCH] Disable coverage testing support inside test venvs
---
tests/conftest.py | 16 +---------------
1 file changed, 1 insertion(+), 15 deletions(-)
diff --git a/tests/conftest.py b/tests/conftest.py
index 0bb69dae6..02da6c573 100644
--- a/tests/conftest.py
+++ b/tests/conftest.py
@@ -311,13 +311,6 @@ def wheel_install(tmpdir_factory, common_wheels):
'wheel')
-@pytest.fixture(scope='session')
-def coverage_install(tmpdir_factory, common_wheels):
- return _common_wheel_editable_install(tmpdir_factory,
- common_wheels,
- 'coverage')
-
-
def install_egg_link(venv, project_name, egg_info_dir):
with open(venv.site / 'easy-install.pth', 'a') as fp:
fp.write(str(egg_info_dir.resolve()) + '\n')
@@ -327,7 +320,7 @@ def install_egg_link(venv, project_name, egg_info_dir):
@pytest.fixture(scope='session')
def virtualenv_template(request, tmpdir_factory, pip_src,
- setuptools_install, coverage_install):
+ setuptools_install, common_wheels):
if request.config.getoption('--use-venv'):
venv_type = 'venv'
@@ -351,13 +344,6 @@ def virtualenv_template(request, tmpdir_factory, pip_src,
subprocess.check_call([venv.bin / 'python', 'setup.py', '-q', 'develop'],
cwd=pip_editable)
- # Install coverage and pth file for executing it in any spawned processes
- # in this virtual environment.
- install_egg_link(venv, 'coverage', coverage_install)
- # zz prefix ensures the file is after easy-install.pth.
- with open(venv.site / 'zz-coverage-helper.pth', 'a') as f:
- f.write('import coverage; coverage.process_startup()')
-
# Drop (non-relocatable) launchers.
for exe in os.listdir(venv.bin):
if not (
--
2.30.0