You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libdca/files/libdca-0.0.7-slibtool.patch

24 lines
956 B

https://code.videolan.org/videolan/libdca/-/issues/4
https://code.videolan.org/videolan/libdca/-/commit/95c4bd8baee808ec563120f463111e2cd6cd240e
https://bugs.gentoo.org/775602
commit c54898d587fda740b10e32055c5464eeae289889
Author: orbea <orbea@riseup.net>
Date: Tue Mar 16 10:21:52 2021 -0700
build: Fix -version-info and -export-symbols-regex typos.
diff --git a/libdca/Makefile.am b/libdca/Makefile.am
index 05bdaca..891fb25 100644
--- a/libdca/Makefile.am
+++ b/libdca/Makefile.am
@@ -5,7 +5,7 @@ lib_LTLIBRARIES = libdca.la
libdca_la_SOURCES = dca_internal.h tables.h tables_quantization.h \
tables_huffman.h tables_fir.h tables_adpcm.h tables_vq.h \
bitstream.h bitstream.c parse.c downmix.c
-libdca_la_LDFLAGS = -no-undefined -version 0:0:0 -export-symbol-regex dca_.*
+libdca_la_LDFLAGS = -no-undefined -version-info 0:0:0 -export-symbols-regex dca_.*
libdca_la_LIBADD = $(LIBDCA_LIBS)
pkgconfigdir = $(libdir)/pkgconfig