You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/blis/files/blis-0.6.0-blas-provider.patch

14 lines
581 B

diff --git a/Makefile b/Makefile
index 2d31fee..7008682 100644
--- a/Makefile
+++ b/Makefile
@@ -659,6 +659,8 @@ else
@$(LINKER) $(SOFLAGS) -o $(LIBBLIS_SO_OUTPUT_NAME) $? $(LDFLAGS)
endif
endif
+ $(LINKER) $(SOFLAGS) -o $(BASE_LIB_PATH)/$(DEB_LIBBLAS) $? $(LDFLAGS) -Wl,--soname,$(DEB_LIBBLAS) -Wl,--version-script=$(LDS_BLAS)
+ $(LINKER) $(SOFLAGS) -o $(BASE_LIB_PATH)/$(DEB_LIBCBLAS) $? $(LDFLAGS) -Wl,--soname,$(DEB_LIBCBLAS) -Wl,--version-script=$(LDS_CBLAS)
# Local symlink for shared library.
# NOTE: We use a '.loc' suffix to avoid filename collisions in case this