You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch

25 lines
1.0 KiB

diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
+++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
@@ -34,7 +34,7 @@
$(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
fs.o: fs.c
- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
+ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
tone.o: tone.c
$(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
--- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
+++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
@@ -523,7 +523,7 @@
int playlen, skip;
if (type == SPEECH)
{
- skip = (187 * wptr->sample_rate) / speed;
+ skip = 0;
playlen = wptr->num_samples - (skip * 2);
if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
}