You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-astronomy/astrometry/files/astrometry-0.67-soname.patch

26 lines
791 B

Author: Ole Streicher <olebole@debian.org>
Description: Add SONAME to libastrometry.so
--- a/blind/Makefile
+++ b/blind/Makefile
@@ -148,7 +148,8 @@
$(RANLIB) $@
$(ENGINE_SO): $(ENGINE_OBJS) $(SLIB)
- $(CC) $(LDFLAGS) $(SHAREDLIBFLAGS) -o $@ $^ $(LDLIBS)
+ $(CC) $(LDFLAGS) $(SHAREDLIBFLAGS) -Wl,-soname,$@.0 -o $@.0 $^ $(LDLIBS)
+ ln -s $@.0 $@
# old and miscellaneous executables that aren't part of the pipeline.
OLDEXECS := plotquads rawstartree checkquads
@@ -233,8 +234,8 @@
done
mkdir -p '$(LIB_INSTALL_DIR)'
@for x in $(INSTALL_LIB); do \
- echo cp $$x '$(LIB_INSTALL_DIR)'; \
- cp $$x '$(LIB_INSTALL_DIR)'; \
+ echo cp -d $$x* '$(LIB_INSTALL_DIR)'; \
+ cp -d $$x* '$(LIB_INSTALL_DIR)'; \
done
mkdir -p '$(PY_INSTALL_DIR)'
@for x in $(PYTHON_INSTALL); do \