You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/conky/files/conky-1.10.8-portmon.patch

21 lines
551 B

--- conky-1.10.8/src/CMakeLists.txt 2019-03-09 08:24:26.315879386 +0100
+++ conky-1.10.8/src/CMakeLists.txt 2019-03-09 08:24:38.555878656 +0100
@@ -220,6 +220,15 @@
install(TARGETS
conky
RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
)
+
+if(BUILD_PORT_MONITORS)
+ install(TARGETS
+ tcp-portmon
+ RUNTIME DESTINATION bin
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+)
+endif(BUILD_PORT_MONITORS)