You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/indilib/files/0.9.1-fix_symlinks.patch

24 lines
2.2 KiB

--- CMakeLists.txt
+++ CMakeLists.txt
@@ -204,15 +204,11 @@
install(TARGETS indi_lx200generic RUNTIME DESTINATION bin )
-file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/make_lx200generic_symlink.cmake
-"exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200classic)\n
-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200autostar)\n
-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200_16)\n
-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200gps)\n
-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200ap)\n
-exec_program(${CMAKE_COMMAND} ARGS -E create_symlink ${BIN_INSTALL_DIR}/indi_lx200generic \$ENV{DESTDIR}${BIN_INSTALL_DIR}/indi_lx200fs2)\n
-")
-set_target_properties(indi_lx200generic PROPERTIES POST_INSTALL_SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/make_lx200generic_symlink.cmake)
+install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200classic\" )" )
+install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200autostar\" )" )
+install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200_16\" )" )
+install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200gps\" )" )
+install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink \"${BIN_INSTALL_DIR}/indi_lx200generic\" \"\$ENV{DESTDIR}/${BUILD_ROOT}${BIN_INSTALL_DIR}/indi_lx200ap\" )" )
#################################################################################
########### Celestron GPS ############