You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/hsetroot/files/hsetroot-1.0.2-underlinking...

23 lines
500 B

--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,8 @@
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
+PKG_CHECK_MODULES(X11, [x11])
+
# Check for imlib2
AC_CHECK_PROGS(imlib2config_cmd, imlib2-config)
if test x$imlib2config_cmd = "x"; then
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,7 @@
bin_PROGRAMS = hsetroot
AM_CFLAGS = @CFLAGS@ @IMLIB2_CFLAGS@ -Wall
-LIBS = @IMLIB2_LIBS@
+LIBS = @IMLIB2_LIBS@ $(X11_LIBS)
hsetroot_SOURCES = hsetroot.c