66 lines
2 KiB
Diff
66 lines
2 KiB
Diff
--- a/nbase/Makefile.in
|
|
+++ b/nbase/Makefile.in
|
|
@@ -12,7 +12,7 @@
|
|
CCOPT =
|
|
DEFS = @DEFS@
|
|
# With GCC, add extra security checks to source code.
|
|
-DEFS += -D_FORTIFY_SOURCE=2
|
|
+DEFS +=
|
|
CPPFLAGS = @CPPFLAGS@
|
|
CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
|
|
STATIC =
|
|
--- a/ncat/Makefile.in
|
|
+++ b/ncat/Makefile.in
|
|
@@ -53,7 +53,7 @@
|
|
LIBS = @LIBS@
|
|
DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
|
|
# With GCC, add extra security checks to source code.
|
|
-DEFS += -D_FORTIFY_SOURCE=2
|
|
+DEFS +=
|
|
INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
|
|
RM = rm -f
|
|
STRIP = @STRIP@
|
|
--- a/nsock/src/Makefile.in
|
|
+++ b/nsock/src/Makefile.in
|
|
@@ -13,7 +13,7 @@
|
|
CCOPT =
|
|
DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
|
|
# With GCC, add extra security checks to source code.
|
|
-DEFS += -D_FORTIFY_SOURCE=2
|
|
+DEFS +=
|
|
INCLS = -I../include
|
|
CFLAGS = @CFLAGS@ $(CCOPT)
|
|
# CFLAGS = -g -Wall $(DEFS) $(INCLS)
|
|
--- a/libnetutil/Makefile.in
|
|
+++ b/libnetutil/Makefile.in
|
|
@@ -5,7 +5,7 @@
|
|
CXXFLAGS = @CXXFLAGS@
|
|
CPPFLAGS = @CPPFLAGS@ $(DEFS)
|
|
DEFS = @DEFS@
|
|
-DEFS += -D_FORTIFY_SOURCE=2
|
|
+DEFS +=
|
|
AR = ar
|
|
RANLIB = @RANLIB@
|
|
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -41,7 +41,7 @@
|
|
# http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
|
|
# Level 1 only makes changes that don't affect "conforming" programs,
|
|
# while level 2 enforces additional restrictions.
|
|
-DEFS += -D_FORTIFY_SOURCE=2
|
|
+DEFS +=
|
|
# For mtrace debugging -- see MTRACE define in main.cc for instructions
|
|
# Should only be enabled during debugging and not in any real release.
|
|
# DEFS += -DMTRACE=1
|
|
--- a/nping/Makefile.in
|
|
+++ b/nping/Makefile.in
|
|
@@ -38,7 +38,7 @@
|
|
# http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
|
|
# Level 1 only makes changes that don't affect "conforming" programs,
|
|
# while level 2 enforces additional restrictions.
|
|
-DEFS += -D_FORTIFY_SOURCE=2
|
|
+DEFS +=
|
|
# For mtrace debugging -- see MTRACE define in main.cc for instructions
|
|
# Should only be enabled during debugging and not in any real release.
|
|
# DEFS += -DMTRACE=1
|