You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/tinycdb/files/tinycdb-gentoo.patch

29 lines
711 B

--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@
CDB_USELIB = $(LIB)
NSS_USELIB = $(PICLIB)
LIBMAP = $(LIBBASE).map
-INSTALLPROG = cdb
+INSTALLPROG = cdb-shared
# The following assumes GNU CC/LD -
# used for building shared libraries only
@@ -59,7 +59,7 @@
ChangeLog NEWS
DEBIANFILES = debian/control debian/rules debian/copyright debian/changelog
-all: static
+all: shared
static: staticlib cdb
staticlib: $(LIB)
nss: $(NSS_CDB)
@@ -128,6 +128,7 @@
do_install = \
while [ "$$1" ] ; do \
+ if [ ! -f $$1 ]; then shift 4; continue; fi; \
if [ .$$4 = .- ]; then f=$$1; else f=$$4; fi; \
d=$(DESTDIR)$$3 ; echo installing $$1 to $$d/$$f; \
[ -d $$d ] || mkdir -p $$d || exit 1 ; \