You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch

23 lines
472 B

--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,7 @@
# Makefile for IFStatus
# Gabriel Montenegro
-GCC = g++
-LDFLAGS = -lncurses
-CFLAGS = -O2 -Wall
+LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
BIN = ifstatus
OBJ = BorderDecorator.o\
@@ -30,7 +28,7 @@
all : ifstatus printdone
ifstatus : $(OBJ)
- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+ $(LINK.cc) $^ $(LDLIBS) -o $@
printdone:
@if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi