You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/nast/files/nast-0.2.0-gentoo.patch

105 lines
3.0 KiB

--- a/configure.ac
+++ b/configure.ac
@@ -83,22 +83,6 @@
# -- libnet --
#
-filechk="yes"
-AC_CHECK_FILE(/usr/lib/libnet.a,, filechk="no")
-if test "$filechk" = "no"; then
- AC_CHECK_FILE(/usr/local/lib/libnet.a, filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include")
-fi
-
-if test "$filechk" = "no"; then AC_MSG_ERROR([
-
-Libnet archive file (libnet.a) not found in /usr or /usr/local!
-
-Libnet-1.1.x Packet Shaping Library is required.
-You can download it from official web site: http://www.packetfactory.net/libnet
-
-])
-fi
-
AC_CHECK_LIB(net, libnet_name2addr4,, AC_MSG_ERROR([
Libnet-1.1.x Packet Shaping Library not found! It's required.
@@ -110,22 +94,6 @@
# -- libpcap --
#
-filechk="yes"
-AC_CHECK_FILE(/usr/lib/libpcap.a,, filechk="no")
-if test "$filechk" = "no"; then
- AC_CHECK_FILE(/usr/local/lib/libpcap.a, filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include")
-fi
-
-if test "$filechk" = "no"; then AC_MSG_ERROR([
-
-Libpcap archive file (libpcap.a) not found in /usr or /usr/local!
-
-Libpcap-0.7.1 Packet Capture Library is required.
-You can download it from official web site: http://www.tcpdump.org/#current
-
-])
-fi
-
AC_CHECK_LIB(pcap, pcap_dispatch,, AC_MSG_ERROR([
Libpcap-0.7.1 Packet Capture Library not found! It's required.
@@ -137,25 +105,7 @@
# -- libncurses support --
#
-filechk="yes"
-AC_CHECK_FILE(/usr/lib/libncurses.a,, filechk="no")
-if test "$filechk" = "no"; then
- AC_CHECK_FILE(/usr/local/lib/libncurses.a, filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include")
-fi
-
-if test "$filechk" = "no";
-then AC_MSG_WARN([
-
-Libncurses archive file (libncurses.a) not found in /usr or /usr/local!
-
-Ncurses library (*) not found in your system.
-You can download it from official web site: http://www.gnu.org/software/ncurses/ncurses.html
-(*): CRT screen handling and optimization package
-
-Building without ncurses menu support (-G flag will doesn't work)
-
-])
-fi
+PKG_CHECK_MODULES(ncurses,ncurses,[LIBS="$LIBS $ncurses_LIBS"],)
ENABLE_NCRS="no"
AC_CHECK_LIB(ncurses, initscr, ENABLE_NCRS="yes"; NCURSES=ncurses/n_nast.o; LIBS="-lncurses $LIBS"; AC_DEFINE(HAVE_LIBNCURSES), AC_MSG_RESULT([
@@ -173,28 +123,6 @@
# --lmenu support--
#
-filechk="yes"
-AC_CHECK_FILE(/usr/lib/libmenu.a,, filechk="no")
-if test "$filechk" = "no"; then
- AC_CHECK_FILE(/usr/local/lib/libmenu.a, filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include")
-fi
-
-if test "$filechk" = "no";
-then AC_MSG_WARN([
-
-Menu archive file (libncurses.a) not found in /usr or /usr/local!
-
-
-Menu library (*) not found in your system.
-You can download it from official web site: http://www.gnu.org/software/ncurses/ncurses.html
-(*): CRT screen handling and optimization package
-
-
-Building without ncurses menu support (-G flag will doesn't work)
-])
-
-fi
-
ENABLE_NCRS="no"
AC_CHECK_LIB(menu, menu_opts_off, ENABLE_NCRS="yes"; MENU=ncurses/n_menu.o; LIBS="-lmenu $LIBS"; AC_DEFINE(HAVE_LIBMENU), AC_MSG_RESULT([